brnd.net
当前位置:首页 >> liBCoCos2DluA.so >>

liBCoCos2DluA.so

Cocos 3.0创建默认的Lua项目时,其Android项目可谓是非常不完整。生成的项目模版。根本就不包含C++的编译。 你的异常实际上告诉你的是,你的项目libs目录下,根本就没有生成SO文件。 我也尝试过去修改这个默认的Android项目模版,不过修改量太大...

自己移除项目里面没必要的库文件吧,比如如果你游戏没用到骨骼动画或者box2d等你可以删除这些。不过现在网速提高,游戏大小已经不是什么大问题了,如果对包大小有要求可以试试上面说的移除。

在Appication.mk里第一行加入 APP_PLATFORM := android-19 (我的就是这个问题),不行的话再试试 改成 APP_PLATFORM := android-9 再不行就多换几个ndk版本试试这个方法。

你应该把你上一句错误贴出来 应该是这个错误: error : expected initializer before 'extern' make.exe: *** [obj/local/armeabi-v7a/objs/pedDetec/PedDetec.o] Error 1 解决的办法: 检查定义的类型或函数是不是少了 ;, 加上就可以了!

1-21 16:39:49.930: E/VLC/LibVLC/Util(13285): WARNING: Unable to read libvlcjni.so; cannot check device ABI! 11-21 16:39:49.930: E/VLC/...

网站首页 | 网站地图
All rights reserved Powered by www.brnd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com